来自 技术 2019-03-16 00:00 的文章

dependencies.dependency.version' for org.hibernate:

开发十年,就只剩下这套架构体系了!>>>

20190315 学习 Spring boot 遇到问题

按照 https://blog.csdn.net/forezp/column/info/15397 学习到SpringBoot非官方教程 | 第十九篇: 验证表单信息https://blog.csdn.net/forezp/article/details/71023817

环境和项目:

ubuntu 18.04 + Eclipse 2018.12创建新 project 中,选择 Spring Starter Project 从以上 SpringBoot非官方教程 直接 copy 代码和 pom 的依赖部分问题:

pom.xml 出现错误!错误提示在 <parent> ,错误地点在 <groupId>org.hibernate</groupId> 的依赖!

1、上官网找找最新版本

http://hibernate.org/validator/显示最新版本Releases : 6.0 latest stable

给 hibernate 依赖 加上 <version>6.0</version> 之后,又显示错误:Missing artifact org.hibernate:hibernate-validator:jar:6.0.11** 换了几个版本号,都是以上错误2、参考

https://blog.csdn.net/oppoppoppo/article/details/55100284

给 hibernate 依赖 加上 <version>${hibernate-validator.version}</version> 之后,ok了!** 但是,会出现黄牌警告:This expression evaluates to 5.3.4.Final The property is defined in org.springframework.boot:spring-boot-dependencies:1.5.2.RELEASE** 初学阶段,不求甚解!先过了这一关再说!往后可能自然就明白问题所在了!